[metapost] MPtoPDF problem

Mojca Miklavec mojca.miklavec.lists at gmail.com
Sun Oct 2 17:07:42 CEST 2005

2005/9/30, Mau <mvs1952 at yahoo.it> wrote:
> Hi!
> I have been using MPtoPDF (included in the MikTeX distribution, under
> Win2K) to convert mp output to pdf. Everything went smoothly until
> the end of July. Now it seems that MPtoPDF cannot produce any output.
> I suspect some problems with a newer version installed automatically
> from MiKTex distribution (MPtoPDF 1.3?)
> My command line is:
> C:\texmf\miktex\bin\mptopdf.exe %n
> where %n is a parameter for the name of the mp file I am working on.
> Does anyone have the same problem?
> Thanks,
> Maurizio

Problems confirmed. I used mptopdf in August and it worked at that
time. I last updated ConTeXt (the package containing mptopdf) on 5th
September (version 2005-07-27).

This is the whole output when mptopdf is run for a simple mp file:

E:\Temp>mptopdf filename
-fmt=mptopdf: unknown option

MPtoPDF 1.3 : filename.* is converted to filename-1.pdf

The last statement doesn't hold (no file created at all). "filename.1"
is OK and mptopdf also works perfectly with the standalone ConTeXt
distribution, but not under MikTeX.

The funny part is also this one (from mptopdf.pl):
     if ($miktex) { $command = "pdfetex -fmt=mptopdf" }
-fmt doesn't seem to exist in MikTeX (any more?). I tried pdfetex
--help, but didn't find any useful switches to compensate for
"-progname=context" except "-alias", but I didn't know how to use it.
I'm a bit lost.

I noticed that the MikTeX package repository was updated in the last
days, so I tried to update the system (for the first time in my life
I've chosen to update only the context.cab since I'm working on
modem), but now the most crucial parts keep crashing (initexmf,
kpsewhich, ...), so I that I can't even work any further and thus
can't check yet if the new package brings any changes or not.


More information about the metapost mailing list