[tex-live] [MacTeX] MacTeX-2013 and BasicTeX-2013 Pretest Versions

Herbert Schulz herbs at wideopenwest.com
Tue Apr 16 14:40:50 CEST 2013

On Apr 14, 2013, at 10:42 PM, Richard Koch <koch at math.uoregon.edu> wrote:

> Folks,
> Karl Berry suggested putting BasicTeX on the TUG tlpretest site, on the
> grounds that the uoregon.edu site is slow for some people.
> I just did that, and I'm uploading the full MacTeX package as well.
> 	mactex-basictex-2013.pkg
> 	mactex-2013.pkg
> Both titles start with mactex because scripts for other platforms
> contain instructions to ignore "mactex….".
> I installed MacTeX-2013 on all supported
> platforms:
> 	Leopard PPC
> 	Leopard Intel
> 	Snow Leopard
> 	Lion
> 	Mountain Lion
> There were no problems. Recall that the user inteface has some
> quirks on Leopard, claiming to install "local-1" and "local-2"
> rather than specific packages. Packages install fine and the
> quirk is due to the age of the Apple Install software on Leopard.
> After installing, I ran a 220 page document with lots of illustrations
> of different types through pdfLatex, and through Latex + DVI.
> This worked fine on all Intel platforms. So while I'd appreciate
> installing on a variety of platforms, we can probably concentrate
> on TeX Live itself, including unusual programs like
> LuaTeX and XeTeX which I did not test.
> My test also worked on Leopard PPC except that Ghostscript
> refused to run on that platform. Testing reveals that both
> gs-X11 and gs-noX11 fail immediately. I'll look into this.
> Recall that it can take up to a day for packages uploaded to
> tug.org to appear on mirror sites.
> Give these install packages to anyone remotely interested. The
> more testing, the better.
> Dick Koch


After having lots of success with TeX Live 2013 (pretest) I finally have discovered that something in LuaLaTeX seems to be broken. I get rather ugly things like

oberdiek.luatex.lua:55: bad 
argument #1 to 'insert' (table expected, got nil)
stack traceback:
	[C]: in function 'insert'
	...ive/2013/texmf-dist/scripts/oberdiek/oberdiek.luatex.lua:55: in main chunk
	[C]: in function 'dofile'
	[string "\directlua "]:6: in main chunk.
l.139   }


89: LuaTeX error ...3/texmf-dist/tex/luatex/luatexbase/luatexbase.loader.lua:53:
 attempt to index field 'loaders' (a nil value)
stack traceback:
	...3/texmf-dist/tex/luatex/luatexbase/luatexbase.loader.lua:53: in main chunk
	[C]: in function 'dofile'
	[string "\directlua "]:1: in main chunk.
l.89   dofile(path)}

when attempting to typeset a sample, but non-trivial (e.g., Hello World) document.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the tex-live mailing list