[tex-live] Initial installing ptex package reports errors

.麻那水無 axnnoindexr11 at gmail.com
Mon May 1 10:33:57 CEST 2017

Dear Norbert,

I talk about my situations:

* I run `/usr/local/texlive/*/bin/*/tlmgr path add` only first.
* And, when I install engine packages, I run `tlmgr path add`.

When I install ptex package via tlmgr, the steps are:

1. tlmgr installs ptex package and creates
2. tlmgr runs fmtutil for rebuilding and fmtutil search ptex in PATH env
3. But, ptex is not in PATH, so, fmtutil raises errors
4. Finally, tlmgr raises fmtutil errors

My cosidering:

* TL bin(/usr/local/texlive/2017/bin/x86_64-linux) is too specific
i.e. when I update texlive 2016 to 2017, I must change PATH bin.
* TeXLive provides `tlmgr path add` action, so, should provide correct
action for `tlmgr path add` user?
* tlmgr install ptex is wrong action initially

However, I have less understanding for TeXLive.
I think this is a bug for `tlmgr path add` users, but, maybe this is a
feature request, isn't?

> Also, we need to make sure that kpsewhich and other bin programs
> are in the PATH in the *correct* version to get the correct files.

Will this be applied to fmtutil?

Hope to hear from you.


Nishiyama Shun

More information about the tex-live mailing list