[tex-live] Problems on windows 10 since tlmgr infrastructure update of 07/Feb/2019

Siep Kroonenberg siepo at bitmuis.nl
Sat Feb 9 10:48:43 CET 2019

On Fri, Feb 08, 2019 at 06:09:40PM +0000, Gopalakrishnan, Krishnakumar wrote:
> Hi,
> Since the tlmgr update of 07/Feb/2019, tlmgr has become unusable on my windows 10 machine (installed on a network-mounted drive). Prior to this, I had no problems with my setup for the last one year.
> Here is one of the issues, https://tex.stackexchange.com/questions/473822/tlmgr-update-self-fails-with-a-weird-error-message-windows-10?noredirect=1#comment1195235_473822
> Wherein the update -self command kept failing.
> I gave up and decided to clean up and do a fresh install, which finally succeeded today.
> But, I still get the following issues:
> $ tlmgr install raleway phonenumbers
> tlmgr.pl: verification of checksum for http://mirror.ox.ac.uk/sites/ctan.org/systems/texlive/tlnet failed: cryptographic signature verification of
>   \\icnas1.cc.ic.ac.uk\kg314\cygwin_64_install\home\kg314\AppData\Local\Temp\FFv90yJjTz\rmR07u7da9<file://icnas1.cc.ic.ac.uk/kg314/cygwin_64_install/home/kg314/AppData/Local/Temp/FFv90yJjTz/rmR07u7da9>
> against
>   http://mirror.ox.ac.uk/sites/ctan.org/systems/texlive/tlnet/tlpkg/texlive.tlpdb.sha512.asc
> failed. Output was
> gpg: can't create '\icnas1.cc.ic.ac.uk\kg314\cygwin_64_install\home\kg314\AppData\Local\Temp\FFv90yJjTz\fnmll3uhca': No such file or directory
> Please report to texlive at tug.org<mailto:texlive at tug.org>
> Error removing //icnas1.cc.ic.ac.uk/kg314/cygwin_64_install/home/kg314/AppData/Local/Temp/FFv90yJjTz/fnmll3uhca at \\icnas1.cc.ic.ac.uk\kg314\texlive\2018\tlpkg\tlperl\lib/File/Temp.pm<file://icnas1.cc.ic.ac.uk/kg314/texlive/2018/tlpkg/tlperl/lib/File/Temp.pm> line 762.
> cannot unlink file for \\icnas1.cc.ic.ac.uk\kg314\cygwin_64_install\home\kg314\AppData\Local\Temp\FFv90yJjTz\fnmll3uhca<file://icnas1.cc.ic.ac.uk/kg314/cygwin_64_install/home/kg314/AppData/Local/Temp/FFv90yJjTz/fnmll3uhca>: Permission denied at \\icnas1.cc.ic.ac.uk\kg314\texlive\2018\tlpkg\tlperl\lib/File/Temp.pm<file://icnas1.cc.ic.ac.uk/kg314/texlive/2018/tlpkg/tlperl/lib/File/Temp.pm> line 784.
> cannot remove directory for //icnas1.cc.ic.ac.uk/kg314/cygwin_64_install/home/kg314/AppData/Local/Temp/FFv90yJjTz: Directory not empty at \\icnas1.cc.ic.ac.uk\kg314\texlive\2018\tlpkg\tlperl\lib/File/Temp.pm line 784<file://icnas1.cc.ic.ac.uk/kg314/texlive/2018/tlpkg/tlperl/lib/File/Temp.pm%20line%20784>.
> After disabling gpg verification, I still get the following error:
> Can't spawn "cmd.exe": No error at //icnas1.cc.ic.ac.uk/kg314/texlive/2018/tlpkg/TeXLive/TLUtils.pm line 2484.
> A suspicious thing is, why is tlmgr reporting path separator as /, instead of \ ?

That is not suspect; internally, TL mostly uses forward slashes,
although it tries to use backslashes when talking to windows.
Surprisingly often, windows does not even care.

What IS suspect is the inability to spawn cmd.exe. Are your path
settings correct?

Also, I saw mention of cygwin in your output. Are you sure that
cygwin is not interfering?

I did some testing myself with a UNC installation and a UNC temp,
but that does not seem to be the problem.

Siep Kroonenberg

More information about the tex-live mailing list