Vanilla TeX Live 2020 - install-tl -gui - automatic platform detection fails when Live System with i386-linux-binaries is running on an x86_64-machine.

ud.usenetcorrespondence at ud.usenetcorrespondence at
Wed Dec 23 00:42:23 CET 2020

Scenario which lead to (now resolved) problems:

I installed vanilla TeX Live 2020 on a Debian-based System,
Knoppix 8.6.1.

Knoppix 8.6.1 is based on Debian/stable (buster), with some
packages from Debian/testing and unstable (sid) for newer
graphics drivers or desktop software packages.
It uses Linux kernel 5.3.5 and Xorg 7.7 (core 1.20.4).

Knoppix 8.6.1 is intended as a Live-System which can be installed
on DVD/USB-stick/(micro) SD-memory-card.

Therefore i386-binaries are used by this system no matter if the
machine in use is i386 or x86_64.

If you install Knoppix 8.6.1 on a recordable medium, e.g., a
USB-stick or a (micro) SD-memory-card, then you can have a so-
called "overlay-partition" where changes to the system can be

If you do this, you have the possibility to "remaster" the system,
i.e., to create a variant of the system where all changes are

More information about Knoppix 8.6.1 can be found at

I ran this Live-System on an x86_64-machine.

Thus the command arch yielded: x86_64
while the command dpkg --print-architecture yielded: i386.

The problem which occurred when installing vanilla TeX Live 2020:

I did my first installing-attempt according to the manual
"TeX Live - Quick install" at
<> :

When you run

    sudo install-tl -gui

, then on x86_64-machines installation for x86_64-linux platform
is pre-entered in the "Advanced" settings of the GUI no matter if
Debian-i386-binaries are in use (as was the case with my

You can't change this pre-entered setting in the GUI-"Advanced"-
screen but only have i386-linux-binaries installed additionally
to the x86_64-linux-binaries.

With my first installing-attempt I didn't realize this, thus
x86_64-linux binaries were installed on a platform where
i386-linux-binaries were in use otherwise.

As the machine in use was an x86_64-machine pdflatex and
lualatex worked nicely.

But xetex/xelatex did not because it depends on things like
fontconfig / libfontconfig1.

The x86_64-linux xetex-binary could not find the x86_64-variants
of fontconfig / libfontconfig1 as only the i386-variants were
installed on the system in question.

This led to error-messages:

    xetex can't find shared library
    xelatex can't find shared library

I was puzzled at first because

    $ sudo apt-get install libfontconfig1

yielded the following message:

    libfontconfig1 is already the latest version (2.13.1-2).

Removing the erroneous x86_64-TeX Live installation and running
the installer with the -force-platform-option, i.e., via the

    sudo ./install-tl -gui -force-platform i386-linux

gave me a TeX Live-installation with i386-binaries where
everything works smoothly.

Why I am posting to the TeX Live mailing list:

While I was in the process of getting to the heart of the
problem, I made it a question at TeX-LaTeX-StackExchange.

texlive-2020 / xetex can't find shared library


At TeX-LaTeX-StackExchange I was asked to do the following:

> you could raise this on texlive list see if the
> platform detection can catch this case



More information about the tex-live mailing list.