Exit Code on tlmgr Update Missing

Norbert Preining norbert at preining.info
Sat Oct 24 16:09:17 CEST 2020

Hi Naveen,

> That error happened when I was running the command
> ```
> tlmgr install standalone preview
> ```

Hmm, it *should* fail. The respective code is
    if (check_for_critical_updates( $localtlpdb, $remotetlpdb)) {
      critical_updates_warning() if (!$::machinereadable);
      if ($opts{"force"}) {
        tlwarn("$prg: Continuing due to --force\n");
      } else {
        if ($::gui_mode) {
          # return here and don't do any updates
          return ($F_ERROR);
        } else {
          die "$prg: Terminating; please see warning above!\n";
so that means if you did *not* pass in --fore, and are not running in
GUI mode, then the
	die "$prg: Terminating; please see warning above!\n";
should have happened. That should also mean a non-zero exit status.

If this didn't happen, that would be strange, or - again - some Windows
specific PITA.

I just tried on Linux, manually reduced the version of texlive.infra,
and then tried to install a package:
[~] tlmgr --repo /home/norbert/public_html/tlnet install 12many
tlmgr: package repository /home/norbert/public_html/tlnet (verified)
tlmgr itself needs to be updated.
Please do this via either
  tlmgr update --self
or by getting the latest updater for Unix-ish systems:
and/or Windows systems:
Then continue with other updates as usual.
tlmgr: Terminating; please see warning above!
[~] echo $?

And the exit code was correctly 255.

I am not sure what I should change here ....



PREINING Norbert                              https://www.preining.info
Accelia Inc. + IFMGA ProGuide + TU Wien + JAIST + TeX Live + Debian Dev
GPG: 0x860CDC13   fp: F7D8 A928 26E3 16A1 9FA0 ACF0 6CAC A448 860C DC13

More information about the tex-live mailing list.